Click here to
show your support
for the NCM
and C5Forum.

Home Discussion Forums Do It Yourself Articles About Your Corvette About This Site

Topic Options
Rate This Topic
#103170 - 04/18/05 07:28 AM 1990 Corvette Problem.........need help!
Burnin21 Offline
Junior Member

Registered: 04/18/05
Posts: 1
Loc: Canada
Hey Guys,

I have a 1990 Corvette Coupe (not the ZR1) and I have a problem I cant figure out. Whenever I start the car it turns over fine and runs until it warms up. As soon as the car warms up it shuts down like someone killed the ignition. I changed the gas, plugs, oil and it still is doing it. Any ideas!? confused

Top
#103171 - 04/20/05 09:44 AM Re: 1990 Corvette Problem.........need help!
J's_vett Offline
Junior Member

Registered: 03/16/05
Posts: 1
Loc: Havelock North Carolina
First I need to know does it show a code? You need to have your vehicle scanned for codes. If there is no codes the first thing I would check is the EGR to ensure they are not stuck in the open position. Second I would check o2 sensor. if good the I would check main fuel filter under the car on the underside on passenger side near exhaust and make sure not clogged. if not them only one thing air ildler motor on throttle body dirty and needs to be cleaned or replaced.
_________________________
JR

Top
#103172 - 04/20/05 11:13 AM Re: 1990 Corvette Problem.........need help!
86Z51 Offline
Member

Registered: 11/24/01
Posts: 1089
Loc: arizona
Ignition module inside of distributor or the coil sitting on top could be the culprit.

Top



Moderator:  BruceF, hcvone, J.B., Redshift