Click here to
show your support
for the NCM
and C5Forum.

Home Discussion Forums Do It Yourself Articles About Your Corvette About This Site

Topic Options
Rate This Topic
#113699 - 07/09/15 04:37 PM shuddering at Idle 2010 GS
miamiguy305 Offline
Full Throttle Member

Registered: 01/18/08
Posts: 586
Loc: Miami , FL
do all these LS3 engines have this shuddering at idle dealer said its normal. I've got no codes but it inst smooth like my C5 was. any tips. if i get the car tuned will that help?
_________________________
found my C6 black on black grand sport 1LT

Top
#113702 - 07/11/15 08:22 AM Re: shuddering at Idle 2010 GS [Re: miamiguy305]
RADARB8 Offline
Full Throttle Member

Registered: 11/20/02
Posts: 2318
Loc: Beautiful NW Arkansas
At 23K miles I am betting that all it needs is a bottle of Techron and a brisk blowing out down some local back roads. Be sure to get the 20gal. size bottle and add it before you fill the tank. Be sure to run it until the tank is almost empty. I run this stuff two or three times each year in all my vehicles. So far with 3 different Vettes I have had zero fuel issues.
http://www.techronworks.com/en-US/produc...es#.VaEKFu1Viko

Top
#113708 - 07/12/15 03:38 PM Re: shuddering at Idle 2010 GS [Re: miamiguy305]
Chewy Offline
Full Throttle Member

Registered: 04/06/03
Posts: 3287
Loc: North Augusta, SC
Techron is a good idea, I'm actually overdue for another bottle in mine

It shouldn't be plugs or wires related with that few miles, but may help if you change the oil. Pull out the dipstick, if it's darker that a light brownish color I'd definitely change it out. If you have a stick and dry sump setup be prepared with 11.5 quarts. Also, LS3 uses a different filter than previous LSx engines, so if you have any leftover filters they won't thread on properly (that lesson was learned the hard way).

Mine is a tad rough for the first minute after firing it up in the morning, but smooths out once warmed up.

Top
#113710 - 07/12/15 07:04 PM Re: shuddering at Idle 2010 GS [Re: miamiguy305]
jrose7004 Offline
Full Throttle Member

Registered: 04/07/04
Posts: 4425
Loc: Oklahoma City, OK
I run Techron through every car I own a couple of times a year as well.

Top
#113716 - 07/14/15 06:15 PM Re: shuddering at Idle 2010 GS [Re: miamiguy305]
miamiguy305 Offline
Full Throttle Member

Registered: 01/18/08
Posts: 586
Loc: Miami , FL
took it in to get it checked turns out Ive got a motor mount that isn't good causing the shaking including my head only 23k and a bad motor mount WOOH. having it replaced on Monday of next week.
_________________________
found my C6 black on black grand sport 1LT

Top
#113717 - 07/15/15 03:14 PM Re: shuddering at Idle 2010 GS [Re: miamiguy305]
jrose7004 Offline
Full Throttle Member

Registered: 04/07/04
Posts: 4425
Loc: Oklahoma City, OK
Good that you found the problem! And even better that it was under warranty.

Top
#113718 - 07/15/15 06:49 PM Re: shuddering at Idle 2010 GS [Re: miamiguy305]
miamiguy305 Offline
Full Throttle Member

Registered: 01/18/08
Posts: 586
Loc: Miami , FL
are there any motor mounts in the market better quality then the OEM ones even though under warranty id consider if i got even less of a vibration in the car. what do you guys think stick with the OEM or go after market for a better ride. recommendations on options would be helpful.
_________________________
found my C6 black on black grand sport 1LT

Top
#113720 - 07/15/15 11:52 PM Re: shuddering at Idle 2010 GS [Re: miamiguy305]
Chewy Offline
Full Throttle Member

Registered: 04/06/03
Posts: 3287
Loc: North Augusta, SC
I had a motor mount break on a 5 year old Olds back in the 90's. My Mother had one break on an 8 year old Lincoln a few years ago. They generally don't fail, so for the price difference no reason for me to go with anything other than oem.

Top



Moderator:  BruceF, hcvone, J.B., Redshift